Dice Game Module 



written by Jeff Wynne


Learner Level

1 – Construction

Module Information

In Level 1 of the Dice Game development, we will construct the game board layout and create the dice movie clip.

Set Up the Flash Document

First we need to create the Flash document that we will be using this module.

1. Select File > New to bring up the New Document window.  Under the general tab, select New Document, select Flash Document, and click OK.

2. Save you new Flash document as “dicegame1.fla” by selecting File>Save As DiceGame1.  Save the file in a folder or location that can be easily accessed.

3. Set up the movie properties by selecting Modify>Document.

4. Select the following properties for your Flash document and click OK

Size:  550 by 400

Background Color #CCFFFF

Frame rate: 15 fps

Creating the Game Board

In the following steps, you will create the game board layout that includes both dynamic and static text boxes and two buttons.

5.  Change Layer 1 name to Buttons

6.   Select the circle tool with no stroke and fill color of #ff0000,  Draw    a circle with a  diameter of 45.  Change W: 45 and H: 45.  Place the circle at X: 31  Y: 230

7.  Select Modify>convert to symbol F8.  Select Button and name it roll.  This will change the red circle to a button.  We will later add script to the button that will roll the dice.

8. Now lets add a static text box with the words Roll Dice.  Place this under the roll dice button.

9. Select the circle tool and draw a second circle with no stroke and fill color #0000FF.  Draw a circle with a diameter of 45.  Change W: 45 and H: 45.  Place the circle at X: 31  Y:  315

10. Select Modify > convert to symbol (F8).  Select Button and name it takepts.  This will change the blue circle to a button.  We will later add script to the button that will allow the player to end their turn.

11. Add a static text box with the words Take Points.  Place this under the takepts button.

Now we will add Dynamic Text boxes to the game board.

12. Add a layer to the time line and name it game.  Place this layer under the button layer.

13. Click on frame 1 on the game layer.  Select the text tool and draw a dynamic text box on the screen.  Change to Dynamic Text.  The size should be 20 and color black.  Change the character to specify ranges ****.  Select show border.  In the Var: box name this “basenum”.  Put this box at X:  425  Y:  40

14. Type Base Number in a static text box and move it under the base number text box. 

15. Set up two dynamic text boxes that will show the total points for each player.  Set the size to 20 and color black.  Specify the ranges and select show border.  Set the Var: to “totpt1” and “totpt2” respectively.  Place the boxes in the lower right hand corner of the game board.  In a static text box type player 1 points and player 2 points and place under the dynamic text boxes.

16. Set up a dynamic text box that will keep track of the points for that particular round.  Place the box at X: 170  Y: 300.  Set the size to 20 and color to black.  Set Var: to  “roundpt”

17. Type Points This Round under the roundpt text box.

18. Finally we will add one additional dynamic text box that will keep track of the number of times the player has rolled the dice in that round.  Set up a dynamic text box and place it on the right hand side of the game screen.  Set the size to 12 and the Var: to “countrd”  Type Number of Rolls under this box.  

19.  Using a static text box type “Player 1” at the top of the game board screen.  Copy this to the game board on from 5.

This completes the game screen.  We will later copy this screen and place it in a different place on the timeline for player two after we add functionality to the buttons in level two.   Now we need to set up a second screen that will give the players information if they “bust” during their turn.  We will place this in a different location on the timeline.

20. Click on frame 5 on the timeline and insert a blank keyframe for both the button and game layer.

21. Go back to frame 1 of the game layer and copy the totpt1 and totpt2 and basenum text boxes. Go to frame 5 of the game layer and paste in place.

22. In a static text box write a message like “ Sorry.  You have rolled your base number.  You get no points for this round”

23. Now we need to create a button that will allow the next player to start their turn.  Click on frame 5 of the button layer Select the circle tool and draw a circle with a diameter of 45.  Select color #006633.  Place the button at X: 77  Y: 290.  Highlight the circle and select Modify > Convert to symbol.  Choose button and call it “next”  Type “Continue with next player” under the button.

If we run our game you will see the game boards flashing back and forth.  To prevent this we will add a stop action to both screens.  

24. Go back to frame 1.  Add a layer and call it actions.  Place this layer on top of the layers.

24 On frame 1 of the action layer select Window>Developmental Panels>actions (F9).  On the actions screen type:   stop()
You have now completed the two major game board screens for the game.  You will copy this screen to another frame on the timeline after adding functionality to the button.

Creating the dice movie clip.

25.  On frame 1 of the game layer draw a die.  Use the line tool and select show grid to help you draw.  Make a copy of this to use for die 2

26. Select the drawing and select Edit>Copy.  With the die drawing selected go to Modify>Conver to symbol.  Choose movie and name it d1.  Delete it from the screen.

27. Paste a copy of the die onto the screen.  Convert this is a movie symbol and name it d2.  Delete this from the screen.

28.  From the Library click on d1 to get into its timeline.  Rename Layer     one to “Die1”.  Add an action layer above the move layer

29.  Add a blank keyframe on frame 10.

30 Move the die to X: 65  Y: 65.  From Modify > Transform> flip horizontal

31.Create a motion tween by selecting it from menu.

32.  On frame 10 of the Move layer add a dynamic text box so it appears inside the die.  Change size to 15 and color black.  Name the variable “dieval”.

33.  stop() in frame 10

34. linkage

35. Repeat steps 27 – 33 for the movie clip d2.  
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2 – Functionality
In Level one we built the game board screens as well as the Dice MovieClips.  

In Level Two we will functionality to the screen buttons that will roll the dice.  We will also define several variables for future use.

In order to begin this module, you must open the DiceGame1.fla you created in Module 1.  Be sure to save this file as DiceGame2.fla.
Rolling the dice

1. On the main timeline click on the roll button.  Bring up the actions screen (F9).  Type the following script.

on(press) {


// attach the dice movie clips to the main game screen


attachMovie(“d1”,”d1”,1);


d1._x=240;


d1._y=180;


attachMovie(“d2”,”d2”,2);


d2._x=300


d2._y=200

}
Test Movie.   On the press of the roll button the dice should roll onto the screen.

  We will now write the script to play the game.  The first thing we have to do is have the computer generate two random numbers that will be placed on the dice movie clips.

2.  Type in the following script at the bottom of the roll button actions



// Gernerates random integers 1-6 and assigns them to variables



die1val = Math.floor(Math.random()*6)+1



die2val = Math.floor(Math.random()*6)+1



// assigns the values to the movie clips



d1.dieval=die1val



d2.dieval=die2val
  We now need to assign the sum of the first roll to the base number.  We will set up a count variable.  We will then use an IfThen statement to check if the roll equals one.  If yes we will assign the sum of the two dice to the basenum text box.  

3.  Type in the following script at the bottom of the roll button actions



// sets up the count variable



count=++



// checks the roll number.  If equal to one set the base number to the sum of the dice.



if(count==1) {



basenum=die1val + die2val



//  This compares the base number to subsequent rolls.  If the base number is equal to the roll the player get no points for the round. It will send the game to frame 5.



} else {


if (basenum==die1val+die2val) {



roundpt=0



gotoandstop(5)


}else{


// adds the points to the roundpt


roundpt=roundpt+die1val+die2val


//sets the countrd to one less than the count.  Base number roll is not included in the roll count


countrd=count-1

}

}
Test the movie.  Run it until the basenumber equals the sum of the two dice.

   Before we add functionality to the Take Points button we need to set up the game board for Player 2.  We will do this by copying most of the existing game board from frame 1 and then making some changes to the Roll Dice button script.

4.  Create a blank keyframe on all three layers of the main timeline on frame 10.

5.  Click on frame 1 of the game timeline and copy.  Click on frame 10 of   the game timeline and paste in place.

6.  Change Player 1 to Player 2

7.  Click on frame 1 of the buttons timeline.  Copy.  Go to frame 10 of the buttons timeline and paste in place.

8.  Click on the frame 10 of the action timeline and type the following script into the actions panel.  This script will resets all data except the total points back to 0 for the start of a new round.


roundpt = 0


count = 0


countrd=0


removeMovieclip(“d1”)


removeMovieclip(“d2”)


basenum=” “
   Since our game will eventually loop back to frame 2 ( the next turn for player 1) we need to add the same script to frame 2 of the action timeline.

We will now add functionality to the Take Points button.

9.  Click on the Take points button and type the following script into its action panel.


on(press){



totpt1=totpt1+roundpt



gotoandstop(10)

}
We now need to add the second game board page to player 2.   

10.  Create a blank keyframe for all three layers on the main timeline on frame 15.  

11.  Click on frame 5 of the game layer and copy.  Go to frame 15 of the game layer and paste in place.

12.  Change player 1 to player 2

13.  Click on frame 5 of the button layer and copy.  Go to frame 15 of the button layer and paste in place.    

   We now need to add functionality to the continue buttons on the 2nd game board pages.

14.  Add the following script to the button on frame 5


on(press){



gotoandstop(10)


}
15.  Add the following script to the button on frame 15


on(press){



gotoandstop(2)


}
   We need to change part of our script on the roll button in frame 10.  Remember we copied the button from frame 1 so we need it to reflect player 2.

16.  The part of the script that directs the game to frame 5 if the player rolls the base number should be changed to frame 15.

  We now need to set up our game to determine the winner.  The game ends when the first player’s total points reach 300.  The player must take the points that puts them over 300 so they could choose to accumulate more than 300 points.

17. Create a blankkeyframe on frame 20.  This will be the page announcing player 1 has won the game.

18. On this page type in a static message that declares player one the winner.

19. Next lets show the winning score.  Since our total points are kept in the variables totpt1 and totpt 2 let’s put two dynamic text boxes with these vars inserted.  

20. Use static text to indicate which box is player one and which is player two.

21. Now lets create a button that allows the players to play the game again.

22. Type the following script for the button:

on(press) {


gotoandstop(2)

}

23. Repeat steps 17 – 22 to set up a the winning page for player 2.

  We now need to add script to our take points button so a winner is determined. We only need to change the script on frame 10 during player two’s turn since we want player two to have an equal number of turns in the game.

24. Click on the button layer of frame 10 and go to the action layer of  the Take Points button.

25. Add the following script.

//this will check if either player’s total points are over 300 and if so which player has more points.

if (totpt1 > 299 and totpt1 > totpt2) {


gotoandstop(20)

}else{


if (totpt2 > 299) {



gotoandstop(21)

}else{

}

}
  We need to also add script to the continue with next player button on frame 15.  We need to do this because if player two rolls his base number the player never presses the Take Points button.

26. Click on frame 15 and go to the action layer of the Continue button.

27. Add the following script.

if (totpt >299) {


gotoandstop(20)

}else{
You should now test the game.  
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3 -Simplicity
   In this module we will create input buttons to personalize the game.  We will create a game option that allows a player to play the computer.

We will next set up an introductory page that will consist of three buttons.  One button will allow the user to access a rules page so they will know how to play the game.  The other two buttons will be game option buttons.  One will direct the user to a Player vs. Player option and the other will be Player vs. Player.
1. On the main timeline click on frame 1 of the game timeline.  Put some static text at the top of the game board that welcomes the players to the game.
2. Click on frame 1 of the actions timeline.
3. Enter a stop()  action script
4. Click on frame 1 of the buttons timeline.
5. Create a button.  Name it rules.  On the button label it Rules of the Game.
6. Type the following action script.
on(press){
gotoandstop(30)


}
We now need to set up a rules page on frame 30 of the main timeline.

7. Click on frame 30 of the game.
8. Type in the following static text.
                   
Rules of the Game

Decide who will go first

Player clicks on roll dice.  The sum of the first roll is your base number for that turn.

Player rolls again.  The sum of the two dice is added to the points for that round.  The player now decides whether to keep the points or roll again.  The player will keep accumulating points as long as the base number is not rolled.  If it is the player loses all points for that round.

Click on Take Points if you want to add the points for the round to your total points.

First player to get to 300 points wins.

We will now need to add a button to take the players back to the main screen.
9. Create a button.  Name it back and type back on the button.
10. Type the following action script on the button.
on(press) {
gotoandstop(1)


}
Run the game.  Check the rules button and the back button.
Now we will create a button that will direct the players to the Player vs. Player mode.
11. Click back on frame 1 of the buttons timeline.
12. Create a button, call it playerplayer and type Player vs. Player on the button.
13. Type the following action script for the button.
on(press){
gotoandstop(25)
}
Now we will set up frame 25 that will allow the two players to type in their names. We will do this by setting up some input text boxes.
14. Click on frame 25 of the game timeline.
15. Using static text, type Player vs. Player at the top.
16. Now change from static text to input text.
17. Create a text box that will be large enough to handle names up to 14 characters.
18. Name this name1 and set the size to 15.  Also make sure the frame is set to on.
19. Copy this text box.
20. Paste in Center and drag it where you want it on the screen.
21. Change the Var: name2   Everything else should be the same.
22. Type a message such as “Enter Name Player1” under name1 input box and “Enter Name Player2” under name 2 box.
23. Now lets add a button to direct the players to the frame 2 which is where our game begins.  Create a button name it start and write script to direct it to frame2
We now have to change our static text boxes in the game to dynamic text boxes so the player’s names will show up.
24. On frame 2 click on the player 1 static text box and change it to dynamic text.  In the Var:  box call it name1
25. Change the static text box under player 1 total points to a dynamic box and in the Var: box call it name2.
26. Do the same for total point for player 2 but in the Var: box call it name2.
Now we need to make similar changes in frames 5, 10, 15, 20 and 21.
We are now going to set up the page which shows the computer playing.  We will have the computer use a simple strategy of roll the dice five times regardless of the base number.
27.  Enter a blank keyframe for each layer on frame 35.
28. Go to frame 10 of the game level and copy.  Go to frame 35 of the game level and paste in place.
29. Do the same with the action level.  **Note**  You do not have to copy the buttons since the computer will run the game internally.
30. Change the name1 and name2 dynamic text boxes to static text box and type in Computer’s Points and Player 2’s points.
We will now enter the script to run the game round for the computer’s turn.  We will have to place this in the action level since this page has no buttons.
31. Click on the action level of frame 35 and type in the following script
// resets the round points, count to zero.  Also this removes the dice movie clips from the screen.
roundpt=0
count=0
countrd=0
removeMovieclip("d1")
removeMovieclip("d2")
basenum=""
//this sets a variable time to 7.  We will count this down to zero which represents the computer rolling five times after the base number is rolled.
time=7
//name a function will use in the setInterval script.
countdown=function(){

time—

// when time reaches 0 then we add our the computer’s points for that round to the total points.  We then stop our loop and move to player 2’s turn that is located going to be located in frame 45.

if(time==0){


totpt1=totpt1+roundpt


clearInterval(timer)


gotoandstop(45)

}else{


attachMovie("d1","d1",1)


d1._x=240


d1._y=180


attachMovie("d2","d2",2)


d2._x=300


d2._y=200


die1val=Math.floor(Math.random()*6)+1


die2val=Math.floor(Math.random()*6)+1


d1.dieval=die1val


d2.dieval=die2val


count++


if(count==1){



basenum=die1val+die2val


}else{



// if the base number is rolled this will stop the loop and move to frame 40.



if(basenum==die1val+die2val){




roundpt=0




clearInterval(timer)




gotoandstop(40)



}else{




roundpt=roundpt+die1val+die2val




countrd=count-1



}


}

}
}
//This sets the variable timer which will be a part of the clearInterval command.  The setInterval command will set up a loop with a pause between each loop.  Setting it to 1000 will set a delay of 1 sec.
timer=setInterval(countdown,1200)
We now need to copy and paste the “sorry” page and the player 2 game page.
32. Set up a blank keyframe for frame 40 on both the button and the game level.
33. Go to frame 15 and copy  the button frames.  Paste it on button level of frame 40. Do the same for the game level.
34. We need to change one piece of script in the button.  Change gotoandstop(20) to gotoandstop(55) and gotoandstop(2) to gotoandstop(45)
35. Change the name1 and name2 dynamic text boxes to static text box and type in Computer’s Points and Player 2’s points
36. Set up a blank keyframe for frame 45 on all three levels.
37. Go to frame 10 and copy the game frame.  Paste in place in the game level of  frame 45.  Do the same thing for the button and the action levels.
38. In the roll number script change the action script command gotoandstop(15) to gotoandstop(50)
39. Change the script on the take points button to read:
on(press){

totpt2=totpt2 + roundpt

if(totpt1>299 and totpt1>totpt2){


gotoandstop(55)

}else{


if(totpt2>299){


   gotoandstop(56)


   }else{

gotoandstop(35)


   }

}
}
We need to now copy and paste the winners screen on frames 55 and 56.
40. Set up a blank keyframe for both the game level and the button level for frame 55.
41. Go to frame 20 and copy the game level.  Paste in place on the game level of frame 55.  Do the same for the button level.
42. Change the name1 and name2 dynamic text boxes to static text box and type in Computer’s Points and Player 2’s points
43. Set up a keyframe for the button and game level on frame 56.  
44. Change the Computer Wins text to Player 2 wins.
Play the computer to test.
